Success!

Feb 14, 2013 at 4:40 AM
Thanks for getting this project together! I was able to get a reply made to a forum thread on my SCCAForums test website.

My site has a LOT of posts, so some of the tapatalk requests seem to take forever, but I was able to at least get into a thread and post!

Looks like the TapaTalk app has some issues with forums that use HTML rendering?
Feb 14, 2013 at 7:01 AM
Congrats!

Can you share your website name?
Feb 14, 2013 at 2:22 PM
It looks like only a couple of my forums will return a list of topics. One in particular I keep trying shows 2868 topics, but never never gets past the loading screen.

Anyone that wants to try can connect TapaTalk to new.sccaforums.com
Coordinator
Feb 14, 2013 at 2:32 PM
Great! I'm glad to know that it is working for someone other than myself. It's odd that they requests are slow, Tapatalk requests the data in a paged manner and for the most part, it uses queries that are nearly identical to those uses by AF itself. I'm not seeing any slowness on my site. Are you accessing it via Wireless or cellular?

And as for the HTML, yes, they expect a weird hybrid of html and bbcode. It took me a long time to figure out the best way to "transform" an HTML post from AF to something that the Tapatalk client would render properly. I had to make some "best guess" type decisions on how to handle some stuff. I'm sure I'll need to tweak it some based on user feedback.

@frozen: You can see it on my site if you search for Greater Iowa Reef Society in tapatalk.
Feb 14, 2013 at 2:34 PM
Well I've had the app running trying to pull back posts from the Almost Anything Goes since I made that post about 10 minutes ago, and it hasn't loaded anything. So I might need to dig into the API a bit further and see about mimicking the requests externally to see what they return.
Coordinator
Feb 14, 2013 at 2:55 PM
I connected up to your site and I was able to return a list of topics for every forum I tried and it was pretty snappy too.

What type of device are you testing with and which version of the client?
Feb 14, 2013 at 2:58 PM
Galaxy Nexus running Android 4.2. Just downloaded tapatalk last night, 2.4.11

I'll go grab my Xoom tablet and see if that performs any differently.
Feb 14, 2013 at 3:32 PM
I just tried on the Xoom (wifi) with the same result (I didn't login with this one, just in case that made a difference)

Try the General Discussion group, and the Almost Anything Goes forum under there to see what i am referring to
Coordinator
Feb 14, 2013 at 3:42 PM
Weird. Topics load in that forum for me fine. Tried it with both Tapatalk and Tapatalk 2 app on my iPhone using WiFi
Feb 14, 2013 at 3:47 PM
Here is what I see on both TapaTalk2 and TapaTalk HD
Image
Image
Coordinator
Feb 14, 2013 at 3:51 PM
I know that the iPhone app requests 20 records at a time. Can you see if the app has some kind of setting that lets you set the page size? If it really is trying to grab all of those topics at once that could definitely be an issue.
Feb 14, 2013 at 3:54 PM
Posts per page is set to 10
Coordinator
Feb 15, 2013 at 3:06 AM
I'm at a loss as to why it's so slow for you. Have you tried accessing another large forum with the Tapatalk client?
Coordinator
Feb 16, 2013 at 12:41 AM
It definitely seems like there is something the get_topic call is returning that the Android client does not like. I'm looking into it now to see if I can figure out what it is (now that I've stolen my daughters android phone for the night).

I notice that the rendering definitely is not working right on Android either. It seems what works right for iOS does not work right for Android. There has to be a common ground somewhere, I'll see if I can figure out what it is.
Feb 16, 2013 at 2:00 AM
Thanks for looking into this
Coordinator
Feb 16, 2013 at 4:16 AM
I just pushed up a new version that should work much better on the Android client.

The post display on Android should now look much better as well.

There are some minor display issues on iOS that I'm having trouble solving. I'm going to punt for now and see if I can get an answer out of the Taptalk people.

-JB
Feb 16, 2013 at 4:38 AM
Woah! Much better! Thanks!
Feb 16, 2013 at 4:41 AM
Well, I can see the Topics now (wouldn't load before), but viewing the actual posts doesn't seem to load anything up currently.
Feb 16, 2013 at 4:44 AM
Edited Feb 16, 2013 at 4:45 AM
Here's what I'm seeing when trying to view my "problems" thread http://new.sccaforums.com/forums/aft/441939

(codeplex edit to fix bad urls)


Image

(codeplex edit to fix bad urls)

Image
Coordinator
Feb 16, 2013 at 4:22 PM
That's strange. I have one user reporting the same thing, but I'm able to read the topics fine on both your forum and mine using the Android client now.

I'll make another run through the get_thread response and make sure everything is being returned properly. It's odd that the exact same client is behaving differently for different people.
Feb 16, 2013 at 9:23 PM
Hrmmm on another android device, where not logged in, it works fine. I'll do some more testing
Coordinator
Feb 16, 2013 at 9:34 PM
Yep, This is proving to be tough to figure out. Their documentation is incomplete and/or hard to interpret, so it's a whole lot of trial and error.
Coordinator
Feb 16, 2013 at 10:02 PM
Ok, I think I see what's going on.

Tapatalk is (in some cases) passes a 4th "return html" value on the "get_thread" method. iOS is passing "true" which XML-RCP.net recognizes as a valid boolean. The Android client is passing "1" which XML-RPC.NET is choking on.

Working on a fix now.
Coordinator
Feb 16, 2013 at 11:16 PM
New Beta Posted.

I had to make a tweak to the XML-RPC.NET component to get it compatible for both clients. It should work properly now. Note that the "CookComputing.XmlRpcV2.dll" is a slightly modified version of the 2.5 release distributed on xml-rpc.net. At some point in the near future, I will post a list of all the changes that I made to that component to make it compatible with Tapatalk. For now, everything I've done should be backwards compatible, so in the unlikely case you have anything else that uses the XML-RPC.NET, it should still work fine.

I have a better understanding now of how the post display works in Tapatalk. The display should be very good on both iOS and Android now.

Let me know how it works for you.

-JB
Feb 16, 2013 at 11:24 PM
That appears to work much better on the phone (the one that wasn't working earlier) I'll try it on the Tablet later on

Question for you, on an IPAD do you see images in this thread? http://new.sccaforums.com/forums/aft/441939 (found under website discussions, sccaforums.com questions/suggestions, thread title Problems: New.SCCAForums.com
Coordinator
Feb 17, 2013 at 12:41 AM
The thread appears great using Tapatalk HD on the iPad.

The images aren't showing up because they are embedded in tables. The tapatalk clients can't display tables, so right now I'm just stripping them out and putting "table removed" in their place.

I'm open to suggestions regarding how to handle these better. Maybe just output the table cell content with a line break for each table row?
Coordinator
Feb 17, 2013 at 2:40 AM
Note you may want to re-download and install .04.

I found/fixed a bug that was causing the Android to crash on reply posts.
Feb 17, 2013 at 2:42 AM
Cool, I noticed the bug, though it never really crashed, and the replies posted